I have been having a lot of trouble getting eclipse working properly. I believe the problem is the javadocs (I get a bunch of ClassLoader errors if I try and run my code as is). When I go to Project > Generate javadoc I select the javadoc.exe correctly, but in the next screen when I try to select the jar files a warning at the top says "Archive references are not supported by the Javadoc tool." Whenever I finish, it terminates the javadoc generation and nothing has changed.

Is javadocs really my problem? I am using eclipse 3.2.2 on ubuntu 8.10 and am still new to the ubuntu file system.