Results 1 to 2 of 2
  1. #1
    smalcat is offline Member
    Join Date
    Nov 2008
    Posts
    6
    Rep Power
    0

    Default plugin works in runtime, does not after deployment

    I have completed my first eclipse plugin and it works perfectly in runtime. When I export it problems begin.

    1. What are the differences between runtime and deployment of the plugin in
    general? I.E. what could I be doing wrong at deployment...

    2. The plugin still works after I deploy it, however when it comes to a line where I am calling an third party plugin it throws an java.lang.NoSuchMethodError:. (It works perfectly in runtime)

    Is there anything I can do?

  2. #2
    smalcat is offline Member
    Join Date
    Nov 2008
    Posts
    6
    Rep Power
    0

    Default

    Solved this myself. Providing solution for someone in the same situation.

    The problem was silly of course. The third part plugin was a different version in source (at runtime) than deployed. They were not compatible.

    Temporary solution: I deployed the third party plugin and now everything works. Waiting for the source of the newer version of third party plugin.

Similar Threads

  1. What are the hot java frames works on demand
    By mallaravi in forum Web Frameworks
    Replies: 1
    Last Post: 10-28-2008, 01:34 PM
  2. deployment
    By Nicholas Jordan in forum NetBeans
    Replies: 4
    Last Post: 07-09-2008, 05:10 PM
  3. how compareTo Method works
    By nanaji in forum Advanced Java
    Replies: 1
    Last Post: 06-22-2008, 07:40 PM
  4. AnyEdit Plugin For Eclipse Plugin
    By JavaForums in forum Eclipse
    Replies: 0
    Last Post: 05-18-2007, 12:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •