Results 1 to 6 of 6
  1. #1
    mathew.vinay is offline Member
    Join Date
    Aug 2008
    Posts
    2
    Rep Power
    0

    Default Eclipse debug not working on Windows Vista

    Hi
    When I try to debug on Eclipse IDE (Dell XPS laptop with Windows Vista), I get an error like "Cannot find a free socket for the debugger". After reading through some forums, I tried disabling the firewall and turning off all McAfee services running in Services.msc. That didnt help. The McAfee icon still remains in the task bar. Can someone help me in fixing this issue. Thanks in advance

    =Mathew

  2. #2
    roots's Avatar
    roots is offline Moderator
    Join Date
    Jan 2008
    Location
    Dallas
    Posts
    293
    Rep Power
    7

    Default

    just for the test, try running eclipse as administrator .. see if it helps ..
    dont worry newbie, we got you covered.

  3. #3
    mathew.vinay is offline Member
    Join Date
    Aug 2008
    Posts
    2
    Rep Power
    0

    Default

    My current user has Administrator privileges.

    =Mathew

  4. #4
    vetalok is offline Member
    Join Date
    Aug 2008
    Posts
    4
    Rep Power
    0

    Default

    turn off antivirus system, turn off firewal, turn of UAC.

  5. #5
    Fosters is offline Member
    Join Date
    Aug 2008
    Posts
    3
    Rep Power
    0

    Default

    Hi Mathew.
    If U have administrator privileges in Vista, U still can't run every application with administrator rights, try roots advice, just right click on eclipse and click Run As Administrator. I hope that helps.

  6. #6
    pmead is offline Member
    Join Date
    Apr 2009
    Posts
    1
    Rep Power
    0

    Default

    I had the same problem with JUnit and the debugger in Eclipse 3.4.1 on Vista. I had to give Eclipse full access from within my anti-virus software.

Similar Threads

  1. Replies: 8
    Last Post: 05-28-2008, 08:00 AM
  2. Java Debug Level
    By keshari in forum New To Java
    Replies: 1
    Last Post: 05-26-2008, 09:23 AM
  3. SciTE-debug 0.9.1
    By Java Tip in forum Java Software
    Replies: 0
    Last Post: 04-10-2008, 05:14 PM
  4. how to debug the servlet
    By tommy in forum Java Servlet
    Replies: 1
    Last Post: 08-06-2007, 09:53 PM
  5. how to debug java code in eclipse
    By rajesh058 in forum Advanced Java
    Replies: 3
    Last Post: 07-26-2007, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •