Hi

I have to run an application which is based on smack library(smack is a library which facilitates xmpp communication between the client and server) on j2me J9VM.
Now, when i run the application on j2me J9VM, i get the "java.security.cert.CertificateParsingException" exception.
I did a bit of research on the net and found that adding a third party library on a J2ME platform can be a problem.
The application runs fine on J2SE platform.
The libraries(JAR files) which i was using on J2SE platform, i copied them into the J2ME machine, added them to the classpath and ran the application.

How do i go about this, people ?
Do i need to obtain a digital sign for the smack library or something of that sort to make it run on j2ME platform ?

Nishant