Results 1 to 2 of 2
  1. #1
    davidfreed is offline Member
    Join Date
    Aug 2014
    Posts
    1
    Rep Power
    0

    Default Maven, "cannot find symbol" error

    Hello My dear Friends,
    I have two projects , operators and analysis.
    they are dependent to each other, operators compiles successfully in maven.
    but analysis has some problems "cannot find symbol".
    Im running maven through ssh, in linux. +

    pom.xml :

    <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <groupId>snsa-storm</groupId>
    <artifactId>snsa-storm-twitteranalysis</artifactId>
    <version>0.0.4-SNAPSHOT</version>
    <name>SNSA Storm Twitter Analysis</name>
    <properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    </properties>
    <repositories>
    <repository>
    <id>twitter4j</id>
    <url>http://twitter4j.org/maven2</url>
    </repository>
    <repository>
    <id>gephi-snapshots</id>
    <name>Gephi Snapshots</name>
    <url>http://nexus.gephi.org/nexus/content/repositories/snapshots/</url>
    </repository>
    <repository>
    <id>gephi-releases</id>
    <name>Gephi Releases</name>
    <url>http://nexus.gephi.org/nexus/content/repositories/releases/</url>
    </repository>
    <repository>
    <id>my-alternate-repository2</id>
    <url>http://repo1.maven.org/maven2/org/openengsb/wrapped/com.jcraft.jsch-all/1.1.0.M2/com.jcraft.jsch-all-1.1.0.M2.jar</url>
    </repository>
    </repositories>

    <dependencies>
    <dependency>
    <groupId>com.google.guava</groupId>
    <artifactId>guava</artifactId>
    <version>14.0.1</version>
    </dependency>
    <dependency>
    <groupId>org.apache.storm</groupId>
    <artifactId>storm-core</artifactId>
    <version>0.9.2-incubating</version>
    <!-- <scope>provided</scope> -->
    <exclusions>
    <exclusion>
    <artifactId>guava</artifactId>
    </exclusion>
    </exclusions>

    </dependency>
    <dependency>
    <groupId>com.floreysoft</groupId>
    <artifactId>jmte</artifactId>
    <version>3.0</version>
    </dependency>

    <dependency>
    <groupId>org.openengsb.wrapped</groupId>
    <artifactId>com.jcraft.jsch-all</artifactId>
    <version>1.1.0.M2</version>
    </dependency>

    <dependency>
    <groupId>org.simpleframework</groupId>
    <artifactId>simple-xml</artifactId>
    <version>2.7</version>
    </dependency>
    <dependency>
    <groupId>commons-cli</groupId>
    <artifactId>commons-cli the results of compile of two projects:#

    compile succes of operators:
    </artifactId>
    <version>1.1</version>
    </dependency>
    <dependency>
    <groupId>junit</groupId>
    <artifactId>junit</artifactId>
    <version>4.11</version>
    <scope>test</scope>
    </dependency>
    <dependency>
    <groupId>snsa-storm</groupId>
    <artifactId>snsa-storm-operators</artifactId>
    <version>0.0.4-SNAPSHOT</version>
    </dependency>
    <dependency>
    <groupId>org.twitter4j</groupId>
    <artifactId>twitter4j-core</artifactId>
    <version>4.0.0</version>
    </dependency>
    <dependency>
    <groupId>it.uniroma1.dis.wsngroup.gexf4j</groupId>
    <artifactId>gexf4j</artifactId>
    <version>[0.4.4-BETA,)</version>
    </dependency>
    <dependency>
    <groupId>com.netflix.astyanax</groupId>
    <artifactId>astyanax</artifactId>
    <exclusions>
    <exclusion>
    <artifactId>slf4j-log4j12</artifactId>
    <groupId>org.slf4j</groupId>
    </exclusion>
    </exclusions>
    <version>1.56.48</version>
    </dependency>
    <dependency>
    <groupId>com.fasterxml.jackson.core</groupId>
    <artifactId>jackson-core</artifactId>
    <version>2.4.1</version>
    </dependency>
    <dependency>
    <groupId>com.fasterxml.jackson.core</groupId>
    <artifactId>jackson-databind</artifactId>
    <version>2.4.1.1</version>
    </dependency>
    <dependency>
    <groupId>com.twitter</groupId>
    <artifactId>hbc-core</artifactId> <!-- or hbc-twitter4j -->
    <version>2.2.0</version> <!-- or whatever the latest version is -->
    </dependency>
    <dependency>
    <groupId>org.geonames</groupId>
    <artifactId>geonames</artifactId>
    <version>1.0</version>
    </dependency>
    <dependency>
    <groupId>org.apache.commons</groupId>
    <artifactId>commons-compress</artifactId>
    <version>1.8</version>
    </dependency>
    <dependency>
    <groupId>net.sf.trove4j</groupId>
    <artifactId>trove4j</artifactId>
    <version>3.0.3</version>
    </dependency>
    <dependency>
    <groupId>org.apache.commons</groupId>
    <artifactId>commons-collections4</artifactId>
    <version>4.0</version>
    </dependency>
    <dependency>
    <groupId>org.apache.commons</groupId>
    <artifactId>commons-lang3</artifactId>
    <version>3.3.2</version>
    </dependency>
    </dependencies>

    <dependencyManagement>
    <dependencies>
    <dependency>
    <groupId>org.apache.httpcomponents</groupId>
    <artifactId>httpclient</artifactId>
    <version>4.2.3</version>
    </dependency>
    </dependencies>
    </dependencyManagement>

    <build>
    <plugins>
    <plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <version>3.1</version>
    <configuration>
    <source>1.7</source>
    <target>1.7</target>
    <encoding>utf-8</encoding>
    </configuration>
    </plugin>
    <plugin>
    <artifactId>maven-assembly-plugin</artifactId>
    <version>2.4</version>
    <configuration>
    <descriptorRefs>
    <descriptorRef>jar-with-dependencies</descriptorRef>
    </descriptorRefs>
    <archive>
    <manifest>
    <mainClass/>
    </manifest>
    </archive>
    </configuration>
    <executions>
    <execution>
    <id>make-assembly</id>
    <phase>package</phase>
    <goals>
    <goal>single</goal>
    </goals>
    </execution>
    </executions>

    </plugin>



    </plugins>
    </build>
    <reporting>
    <plugins>
    <plugin>
    <groupId>org.codehaus.mojo</groupId>
    <artifactId>findbugs-maven-plugin</artifactId>
    <version>2.5.1</version>
    </plugin>
    </plugins>
    </reporting>
    </project>


    thank you so much in advance.


    Best,
    david
    Last edited by davidfreed; 08-09-2014 at 06:07 AM.

  2. #2
    FON
    FON is offline Senior Member
    Join Date
    Dec 2009
    Location
    Belgrade, Serbia
    Posts
    366
    Rep Power
    6

    Default Re: Maven, "cannot find symbol" error

    run mvn command with -X argument to get details on error.
    search for problems regarding - wrong imports, bad class names method names, wrong params or variables used

Similar Threads

  1. "Error cannot find symbol" "throws BadLocationException"
    By Daniel Silvester in forum New To Java
    Replies: 8
    Last Post: 07-02-2013, 02:53 AM
  2. Pls solve my "Cannot find symbol" error
    By yvijai in forum New To Java
    Replies: 5
    Last Post: 05-19-2012, 12:17 AM
  3. Strange "Cannot find symbol" error...
    By JimmyD in forum New To Java
    Replies: 8
    Last Post: 04-19-2012, 10:39 PM
  4. Error "can not find symbol variable"
    By FullMetalHollow in forum New To Java
    Replies: 5
    Last Post: 10-04-2009, 10:51 PM
  5. "Cannont find symbol Constructor" error
    By Welsh in forum New To Java
    Replies: 7
    Last Post: 01-25-2008, 01:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •