please help
currently I'm building a system that allowing the restful (jersey 1.12) to be invoked by some webservices (Axis2)
the scenario is like this:

client --> webservice (Axis2) --> restful services (Jersey 1.12) ... run in the tomcat Apache 7
there's some problem occurs whenever I try to invoke the jersey. says that

java.lang.ClassNotFoundException: com.sun.ws.rs.ext.RuntimeDelegateImpl

here the complete error in apache,

[ERROR] java.lang.ClassNotFoundException: com.sun.ws.rs.ext.RuntimeDelegateImpl
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.
java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAcces
sorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.apache.axis2.rpc.receivers.RPCUtil.invokeServi ceClass(RPCUtil.jav
a:212)
at org.apache.axis2.rpc.receivers.RPCMessageReceiver. invokeBusinessLogic
(RPCMessageReceiver.java:117)
at org.apache.axis2.receivers.AbstractInOutMessageRec eiver.invokeBusines
sLogic(AbstractInOutMessageReceiver.java:40)
at org.apache.axis2.receivers.AbstractMessageReceiver .receive(AbstractMe
ssageReceiver.java:110)
at org.apache.axis2.engine.AxisEngine.receive(AxisEng ine.java:181)
at org.apache.axis2.transport.http.HTTPTransportUtils .processHTTPPostReq
uest(HTTPTransportUtils.java:172)
at org.apache.axis2.transport.http.AxisServlet.doPost (AxisServlet.java:1
46)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:641)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:722)
at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(Appl
icationFilterChain.java:305)
at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationF
ilterChain.java:210)
at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperV
alve.java:224)
at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextV
alve.java:169)
at org.apache.catalina.authenticator.AuthenticatorBas e.invoke(Authentica
torBase.java:472)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.j
ava:168)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.j
ava:98)
at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:
927)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineVal
ve.java:118)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.jav
a:407)
at org.apache.coyote.http11.AbstractHttp11Processor.p rocess(AbstractHttp
11Processor.java:987)
at org.apache.coyote.AbstractProtocol$AbstractConnect ionHandler.process(
AbstractProtocol.java:579)
at org.apache.tomcat.util.net.JIoEndpoint$SocketProce ssor.run(JIoEndpoin
t.java:307)
at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.
java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor
.java:603)
at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: com.sun
.ws.rs.ext.RuntimeDelegateImpl
at javax.ws.rs.ext.RuntimeDelegate.getInstance(Runtim eDelegate.java:112)

at javax.ws.rs.core.UriBuilder.newInstance(UriBuilder .java:69)
at javax.ws.rs.core.UriBuilder.fromUri(UriBuilder.jav a:80)
at javax.ws.rs.core.UriBuilder.fromUri(UriBuilder.jav a:99)
at wsPackage.TweetClass.getBaseURI(TweetClass.java:46 )
at wsPackage.TweetClass.tweet(TweetClass.java:39)
... 29 more
Caused by: java.lang.ClassNotFoundException: com.sun.ws.rs.ext.RuntimeDelegateIm
pl
at org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoa
der.java:1701)
at org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoa
der.java:1546)
at javax.ws.rs.ext.FactoryFinder.newInstance(FactoryF inder.java:44)
at javax.ws.rs.ext.FactoryFinder.find(FactoryFinder.j ava:141)
at javax.ws.rs.ext.RuntimeDelegate.getInstance(Runtim eDelegate.java:95)
... 34 more

I guess it's caused by missing some jars either in apache lib or in my axisservice lib
actually i put all the jersey jars into the axisservice lib,,, I have test the axis2 --> restful with the webservice test explorer in eclipse, it works just fine
but whenever i try it from a client (as i showed in the scenario above) it doesnt work.

Please advice, thanks in advance