Results 1 to 2 of 2
  1. #1
    maddy23285 is offline Member
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    0

    Default Facing problem with spring web application deployed in tomcat 7.0 hosted on ubuntu

    Hi,

    I have a spring web application deployed in tomcat 7.0 hosted on ubuntu server 12.4. But everytime when I try to access the application it always shows 404 resource is not available as shown in screenshot below.

    Facing problem with spring web application deployed in tomcat 7.0 hosted on ubuntu-1.png


    But after hitting F5 for 3 or more times it works and comes to login page. as shown in screenshot below.

    Facing problem with spring web application deployed in tomcat 7.0 hosted on ubuntu-3.png

    then

    Facing problem with spring web application deployed in tomcat 7.0 hosted on ubuntu-4.png

    It always needs refresh to show page correctly after each form submit request even clicking on login button also shows 404 resource not available error but again after hitting F5 for few times it starts to work. I don't know what is going wrong here.

    Facing problem with spring web application deployed in tomcat 7.0 hosted on ubuntu-6.png

    then after hitting F5 for few times

    Facing problem with spring web application deployed in tomcat 7.0 hosted on ubuntu-7.png

    I tried this web application with same tomcat version on windows server and its working absolutely fine.

    Can anyone help me to sort this out.??

    Lots of thanks in advance.
    Last edited by maddy23285; 10-08-2013 at 01:45 PM.

  2. #2
    maddy23285 is offline Member
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    0

    Default Re: Facing problem with spring web application deployed in tomcat 7.0 hosted on ubunt

    Hi guys,

    I solved this issue

    Just changed

    <Connector connectionTimeout="60000" port="8585" protocol="HTTP/1.1" redirectPort="8443"/>

    To

    <Connector connectionTimeout="20000" port="8585" protocol="HTTP/1.1" redirectPort="8443"/>


Similar Threads

  1. Replies: 1
    Last Post: 03-07-2013, 10:32 AM
  2. Replies: 0
    Last Post: 07-06-2012, 02:22 PM
  3. a problem about my jsf-tomcat application
    By orkun in forum JavaServer Pages (JSP) and JSTL
    Replies: 0
    Last Post: 02-23-2011, 09:47 AM
  4. Ubuntu 10.10 Tomcat 6 & Servlets newbie
    By midnight1111 in forum Java Applets
    Replies: 1
    Last Post: 12-07-2010, 09:59 AM
  5. Run Deployed JAR Files From Web Start Application
    By jonkri in forum Advanced Java
    Replies: 6
    Last Post: 04-28-2010, 03:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •