Results 1 to 5 of 5
  1. #1
    ajeeb is offline Member
    Join Date
    Dec 2008
    Posts
    30
    Rep Power
    0

    Default Compatibility of WebSphere Application Server 6.1 with JRE 1.4.2

    Hi,

    I need to migrate a java based application currently running fine in WAS 5.3 server on Solaris using the WAS runtime of 1.4.2.

    I need to move this application to WAS 6.1 server again on Solaris and use the WAS runtime 1.4.2.

    I need to know is WAS 6.1 compatible with JRE 1.4.2?

    If not, I am afraid I will have to use JRE 1.5 on WAS 6.1 which would mean possible changes in the application.

    Please let me know or direct me to appropriate sources for reading which you guys already know might be helpful.

    ~Regards,
    Ajeeb

  2. #2
    masijade is offline Senior Member
    Join Date
    Jun 2008
    Posts
    2,571
    Rep Power
    9

    Default

    Quote Originally Posted by ajeeb View Post
    Please let me know or direct me to appropriate sources for reading which you guys already know might be helpful.
    Uhm, the manual?

  3. #3
    ajeeb is offline Member
    Join Date
    Dec 2008
    Posts
    30
    Rep Power
    0

    Default

    Please let me know of any appropriate manual if you already have or even have the links to. Search engines gives me a number of IBM redbook but nothing about the compatibility question I asked.

  4. #4
    Tolls is offline Moderator
    Join Date
    Apr 2009
    Posts
    11,755
    Rep Power
    19

    Default

    IBM wiki for websphere.

    Now, Java 1.4 started end of life a few months after 6.1 was released...and 6.1 was released over a year after Java 1.5 was released.

    I expect it's compatible, however since 1.4 is dead I would recommend upgrading anyway...I doubt you'll get much support help for dead software.

  5. #5
    masijade is offline Senior Member
    Join Date
    Jun 2008
    Posts
    2,571
    Rep Power
    9

    Default

    The documentation that came with the server. It will say what version of the JVM is required. You can, then, try to run on a lower version of the JDK, although it probably wouldn't work, and even if you could get it to work, it wouldn't be supported.

Similar Threads

  1. application server
    By salmonel in forum Enterprise JavaBeans (EJB)
    Replies: 0
    Last Post: 09-08-2009, 10:44 AM
  2. Unable to start WEbSphere server using RAD IDE
    By uppaluru in forum Other IDEs
    Replies: 1
    Last Post: 02-13-2008, 07:51 AM
  3. Application server
    By dmis in forum Enterprise JavaBeans (EJB)
    Replies: 0
    Last Post: 11-12-2007, 01:12 PM
  4. Websphere Application Server
    By Albert in forum Advanced Java
    Replies: 1
    Last Post: 07-05-2007, 06:52 PM
  5. Replies: 4
    Last Post: 06-05-2007, 01:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •